Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-598

Target runtime versions in new SwitchYard project wizard is not populated

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Out of Date
    • Affects Version/s: 0.3
    • Fix Version/s: None
    • Component/s: tooling
    • Labels:
      None

      Description

      The runtime versions list in the new SwitchYard project wizard is not populated.

      The problem appears to be related to the initialization of the Maven functionality within Eclipse. The SwitchYard tooling contributes a "custom" repository definition that is used when searching for available runtime versions. This definition is not loaded until the core Maven tooling is initialized, which is when the wizard queries for the available versions. The Maven tooling processes the contributed repositories asynchronously one second after the Maven plugins are activated.

      Note, once the Maven plugins are active (workspace with Maven projects, Maven repositories view, etc.), the list is populated appropriately.

        Gliffy Diagrams

          Activity

          Hide
          rcernich Rob Cernich added a comment -

          Not sure if we can fix this, as it is a timing issue inside m2e.

          Lowering the priority since the problem only exists if the m2e plugins have not been activated.

          Show
          rcernich Rob Cernich added a comment - Not sure if we can fix this, as it is a timing issue inside m2e. Lowering the priority since the problem only exists if the m2e plugins have not been activated.
          Hide
          kcbabo Keith Babo added a comment -

          I'm happy with our current solution. Any reason why we shouldn't close this JIRA?

          Show
          kcbabo Keith Babo added a comment - I'm happy with our current solution. Any reason why we shouldn't close this JIRA?
          Hide
          rcernich Rob Cernich added a comment -

          I'm going to mark this as out of date. We currently hard-code the version to the latest released version of SwitchYard, so even if the list is empty, you get a good default value.

          Show
          rcernich Rob Cernich added a comment - I'm going to mark this as out of date. We currently hard-code the version to the latest released version of SwitchYard, so even if the list is empty, you get a good default value.
          Hide
          apodhrad Andrej Podhradsky added a comment -

          Closed as outdated, works fine in

          • JBDS 7.1.1.GA + JBDS-IS 7.1.0.GA
          • JBDS 8.1.0.GA + JBDS-IS 8.0.2.GA
          Show
          apodhrad Andrej Podhradsky added a comment - Closed as outdated, works fine in JBDS 7.1.1.GA + JBDS-IS 7.1.0.GA JBDS 8.1.0.GA + JBDS-IS 8.0.2.GA

            People

            • Assignee:
              rcernich Rob Cernich
              Reporter:
              rcernich Rob Cernich
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development