Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2976

Problem installing switchyard from devstudio IS 10.0.0.GA site into devstudio rpm

    Details

      Description

      I tried to install switchyard and this error appeared in the log after restart:

      !ENTRY org.switchyard.tools.core 4 0 2016-11-23 09:45:11.118
      !MESSAGE FrameworkEvent ERROR
      !STACK 0
      org.osgi.framework.BundleException: Could not resolve module: org.switchyard.tools.core [1390]
        Bundle was not resolved because of a uses contraint violation.
        org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource org.switchyard.tools.core [osgi.identity; osgi.identity="org.switchyard.tools.core"; type="osgi.bundle"; version:Version="2.2.0.Final-v20161110-1803-B65"] because it is exposed to package 'org.slf4j' from resources org.slf4j.api [osgi.identity; type="osgi.bundle"; version:Version="1.7.2.v20121108-1250"; osgi.identity="org.slf4j.api"] and slf4j.api [osgi.identity; type="osgi.bundle"; version:Version="1.7.4"; osgi.identity="slf4j.api"] via two dependency chains.
      

      See whole log here rh-eclipse46-devstudio10.2.log.switchyard_plugin_test.txt.

      Tested in 10.2-0.20161123.1426.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  bfitzpat Brian Fitzpatrick
                  Reporter:
                  lvalach Lukáš Valach
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: