Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2867

Resolve issues with CamelAMQPBindingQuickstartTest.java

    Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: component-camel
    • Labels:
      None

      Description

      CamelAMQPBindingTest is throwing this :

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-amqp [166]: Unable to resolve 166.0: missing requirement [166.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.qpid.amqp_1_0.jms.impl)(version>=0.20.0)(!(version>=1.0.0)))

      It looks like the issue is with the camel-amqp component feature. Once this issue is fixed or patch we need to re-enable the CamelAMQPBindingTest in release/karaf/tests/pom.xml.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  tcunning Thomas Cunningham
                  Reporter:
                  tcunning Thomas Cunningham
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: