Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2547

demo-policy-security-basic - Required policy "authorization" is not provided on karaf

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: quickstarts
    • Labels:
      None

      Description

      According to README, following should succeed:

      mvn exec:java -Dexec.args="confidentiality clientAuthentication" -Djavax.net.ssl.trustStore=connector.jks -Dorg.switchyard.component.soap.client.port=8183
      

      But I got this instead:

      2015-02-19 00:05:14,354 | INFO  | qtp298264726-77  | WorkService                      | 171 - org.apache.cxf.cxf-core - 3.0.2 | Inbound Message
      ----------------------------
      ID: 1
      Address: https://localhost:8183/cxf/policy-security-basic/WorkService
      Encoding: UTF-8
      Http-Method: POST
      Content-Type: text/xml; charset=UTF-8
      Headers: {accept-encoding=[gzip,deflate], Authorization=[Basic a2VybWl0OnRoZS1mcm9nLTE=], connection=[keep-alive], Content-Length=[447], content-type=[text/xml; charset=UTF-8], Host=[localhost:8183], User-Agent=[Apache-HttpClient/4.3.5 (java 1.5)]}
      Payload: <?xml version="1.0" encoding="UTF-8"?>
      <soap:Envelope
          xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
          xmlns:policy-security-basic="urn:switchyard-quickstart-demo:policy-security-basic:0.1.0">
          <soap:Header/>
          <soap:Body>
              <policy-security-basic:doWork>
                  <work>
                      <command>CMD-1424271913810</command>
                  </work>
              </policy-security-basic:doWork>
          </soap:Body>
      </soap:Envelope>
      
      --------------------------------------
      2015-02-19 00:05:14,628 | WARN  | qtp298264726-77  | PhaseInterceptorChain            | 171 - org.apache.cxf.cxf-core - 3.0.2 | Application {urn:switchyard-quickstart-demo:policy-security-basic:0.1.0}WorkService#{urn:switchyard-quickstart-demo:policy-security-basic:0.1.0}doWork has thrown exception, unwinding now
      org.apache.cxf.binding.soap.SoapFault: SWITCHYARD014014: Required policies have not been provided: {http://docs.oasis-open.org/ns/opencsa/sca/200912}authorization
      	at org.apache.cxf.jaxws.AbstractJAXWSMethodInvoker.createFault(AbstractJAXWSMethodInvoker.java:257)[183:org.apache.cxf.cxf-rt-frontend-jaxws:3.0.2]
      	at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:129)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.jaxws.AbstractJAXWSMethodInvoker.invoke(AbstractJAXWSMethodInvoker.java:232)[183:org.apache.cxf.cxf-rt-frontend-jaxws:3.0.2]
      	at org.apache.cxf.jaxws.JAXWSMethodInvoker.invoke(JAXWSMethodInvoker.java:69)[183:org.apache.cxf.cxf-rt-frontend-jaxws:3.0.2]
      	at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:75)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.interceptor.ServiceInvokerInterceptor$1.run(ServiceInvokerInterceptor.java:59)[171:org.apache.cxf.cxf-core:3.0.2]
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.0_75]
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_75]
      	at org.apache.cxf.interceptor.ServiceInvokerInterceptor$2.run(ServiceInvokerInterceptor.java:126)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.workqueue.SynchronousExecutor.execute(SynchronousExecutor.java:37)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage(ServiceInvokerInterceptor.java:131)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:307)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:121)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke(AbstractHTTPDestination.java:243)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.ServletController.invokeDestination(ServletController.java:223)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:197)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:149)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.CXFNonSpringServlet.invoke(CXFNonSpringServlet.java:171)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.handleRequest(AbstractHTTPServlet.java:290)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.doPost(AbstractHTTPServlet.java:209)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:595)[54:org.apache.geronimo.specs.geronimo-servlet_3.0_spec:1.0]
      	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.service(AbstractHTTPServlet.java:265)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:503)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(HttpServiceServletHandler.java:69)[69:org.ops4j.pax.web.pax-web-jetty:3.1.2]
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(HttpServiceContext.java:240)[69:org.ops4j.pax.web.pax-web-jetty:3.1.2]
      	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:77)[69:org.ops4j.pax.web.pax-web-jetty:3.1.2]
      	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.Server.handle(Server.java:370)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:982)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1043)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:865)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.io.nio.SslConnection.handle(SslConnection.java:196)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at java.lang.Thread.run(Thread.java:745)[:1.7.0_75]
      Caused by: javax.xml.ws.soap.SOAPFaultException: SWITCHYARD014014: Required policies have not been provided: {http://docs.oasis-open.org/ns/opencsa/sca/200912}authorization
      	at org.switchyard.component.soap.InboundHandler.composeResponse(InboundHandler.java:384)
      	at org.switchyard.component.soap.InboundHandler.invoke(InboundHandler.java:348)
      	at org.switchyard.component.soap.endpoint.BaseWebService.invoke(BaseWebService.java:110)
      	at org.switchyard.component.soap.endpoint.BaseWebService.invoke(BaseWebService.java:40)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.7.0_75]
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)[:1.7.0_75]
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[:1.7.0_75]
      	at java.lang.reflect.Method.invoke(Method.java:606)[:1.7.0_75]
      	at org.apache.cxf.service.invoker.AbstractInvoker.performInvocation(AbstractInvoker.java:181)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:97)[171:org.apache.cxf.cxf-core:3.0.2]
      	... 47 more
      2015-02-19 00:05:14,648 | ERROR | qtp298264726-77  | ver1_1                           | 189 - org.apache.servicemix.bundles.saaj-impl - 1.3.9.2 | SAAJ0303: Operation getFaultSubcodes not supported by SOAP 1.1 
      2015-02-19 00:06:42,271 | INFO  | qtp298264726-79  | WorkService                      | 171 - org.apache.cxf.cxf-core - 3.0.2 | Inbound Message
      ----------------------------
      ID: 2
      Address: https://localhost:8183/cxf/policy-security-basic/WorkService
      Encoding: UTF-8
      Http-Method: POST
      Content-Type: text/xml; charset=UTF-8
      Headers: {accept-encoding=[gzip,deflate], Authorization=[Basic a2VybWl0OnRoZS1mcm9nLTE=], connection=[keep-alive], Content-Length=[447], content-type=[text/xml; charset=UTF-8], Host=[localhost:8183], User-Agent=[Apache-HttpClient/4.3.5 (java 1.5)]}
      Payload: <?xml version="1.0" encoding="UTF-8"?>
      <soap:Envelope
          xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"
          xmlns:policy-security-basic="urn:switchyard-quickstart-demo:policy-security-basic:0.1.0">
          <soap:Header/>
          <soap:Body>
              <policy-security-basic:doWork>
                  <work>
                      <command>CMD-1424272001978</command>
                  </work>
              </policy-security-basic:doWork>
          </soap:Body>
      </soap:Envelope>
      
      --------------------------------------
      2015-02-19 00:06:42,285 | WARN  | qtp298264726-79  | PhaseInterceptorChain            | 171 - org.apache.cxf.cxf-core - 3.0.2 | Application {urn:switchyard-quickstart-demo:policy-security-basic:0.1.0}WorkService#{urn:switchyard-quickstart-demo:policy-security-basic:0.1.0}doWork has thrown exception, unwinding now
      org.apache.cxf.binding.soap.SoapFault: SWITCHYARD014014: Required policies have not been provided: {http://docs.oasis-open.org/ns/opencsa/sca/200912}authorization
      	at org.apache.cxf.jaxws.AbstractJAXWSMethodInvoker.createFault(AbstractJAXWSMethodInvoker.java:257)[183:org.apache.cxf.cxf-rt-frontend-jaxws:3.0.2]
      	at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:129)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.jaxws.AbstractJAXWSMethodInvoker.invoke(AbstractJAXWSMethodInvoker.java:232)[183:org.apache.cxf.cxf-rt-frontend-jaxws:3.0.2]
      	at org.apache.cxf.jaxws.JAXWSMethodInvoker.invoke(JAXWSMethodInvoker.java:69)[183:org.apache.cxf.cxf-rt-frontend-jaxws:3.0.2]
      	at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:75)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.interceptor.ServiceInvokerInterceptor$1.run(ServiceInvokerInterceptor.java:59)[171:org.apache.cxf.cxf-core:3.0.2]
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.0_75]
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_75]
      	at org.apache.cxf.interceptor.ServiceInvokerInterceptor$2.run(ServiceInvokerInterceptor.java:126)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.workqueue.SynchronousExecutor.execute(SynchronousExecutor.java:37)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage(ServiceInvokerInterceptor.java:131)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:307)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:121)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke(AbstractHTTPDestination.java:243)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.ServletController.invokeDestination(ServletController.java:223)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:197)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.ServletController.invoke(ServletController.java:149)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.CXFNonSpringServlet.invoke(CXFNonSpringServlet.java:171)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.handleRequest(AbstractHTTPServlet.java:290)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.doPost(AbstractHTTPServlet.java:209)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:595)[54:org.apache.geronimo.specs.geronimo-servlet_3.0_spec:1.0]
      	at org.apache.cxf.transport.servlet.AbstractHTTPServlet.service(AbstractHTTPServlet.java:265)[181:org.apache.cxf.cxf-rt-transports-http:3.0.2]
      	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:503)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(HttpServiceServletHandler.java:69)[69:org.ops4j.pax.web.pax-web-jetty:3.1.2]
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(HttpServiceContext.java:240)[69:org.ops4j.pax.web.pax-web-jetty:3.1.2]
      	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:77)[69:org.ops4j.pax.web.pax-web-jetty:3.1.2]
      	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.Server.handle(Server.java:370)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:982)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1043)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:865)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.io.nio.SslConnection.handle(SslConnection.java:196)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)[60:org.eclipse.jetty.aggregate.jetty-all-server:8.1.15.v20140411]
      	at java.lang.Thread.run(Thread.java:745)[:1.7.0_75]
      Caused by: javax.xml.ws.soap.SOAPFaultException: SWITCHYARD014014: Required policies have not been provided: {http://docs.oasis-open.org/ns/opencsa/sca/200912}authorization
      	at org.switchyard.component.soap.InboundHandler.composeResponse(InboundHandler.java:384)
      	at org.switchyard.component.soap.InboundHandler.invoke(InboundHandler.java:348)
      	at org.switchyard.component.soap.endpoint.BaseWebService.invoke(BaseWebService.java:110)
      	at org.switchyard.component.soap.endpoint.BaseWebService.invoke(BaseWebService.java:40)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.7.0_75]
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)[:1.7.0_75]
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[:1.7.0_75]
      	at java.lang.reflect.Method.invoke(Method.java:606)[:1.7.0_75]
      	at org.apache.cxf.service.invoker.AbstractInvoker.performInvocation(AbstractInvoker.java:181)[171:org.apache.cxf.cxf-core:3.0.2]
      	at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:97)[171:org.apache.cxf.cxf-core:3.0.2]
      	... 47 more
      2015-02-19 00:06:42,289 | ERROR | qtp298264726-79  | ver1_1                           | 189 - org.apache.servicemix.bundles.saaj-impl - 1.3.9.2 | SAAJ0303: Operation getFaultSubcodes not supported by SOAP 1.1 
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  virchete David virgil naranjo
                  Reporter:
                  igarashitm tomohisa igarashi
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: