Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2514

Deployment issues with JBoss Tools 4.2.2.Final

    Details

    • Steps to Reproduce:
      Hide

      Ok. I have reproduced the user's issues with the following steps:

      1) https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunasr1a
      2) Install JBoss Tools 4.2.2.Final from the Eclipse Marketplace
      3) Install SwitchYard Tools from http://download.jboss.org/jbosstools/updates/development/luna/integration-stack/earlyaccess/
      4) Create a new Wildfly 8.1.0.Final installation (http://wildfly.org/downloads/) and overlay the switchyard-installer-wildfly-2.0.0.Beta1.zip (http://switchyard.jboss.org/downloads)
      5) Create a Server configuration in my workspace for a Wildfly 8.x server
      6) Start the server (seems fine up to this point)
      7) Import my trusty camel-file-binding quickstart from my SwitchYard quickstarts github repo (https://github.com/jboss-switchyard/quickstarts)
      7) Right-click on the server and Add/Remove... - I see a little red (icon missing) graphic to the left of my SwitchYard quickstart project, but it is in the list.
      8) Add it and hit OK.
      9) It seems to deploy ok in the server console and shows up in the server tree with the same icon missing
      10) Go to http://localhost:9990/console/App.html#sy-apps to look at my running server and the deployed application does not show up
      11) Try to undeploy - it will not undeploy at all.

      Show
      Ok. I have reproduced the user's issues with the following steps: 1) https://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunasr1a 2) Install JBoss Tools 4.2.2.Final from the Eclipse Marketplace 3) Install SwitchYard Tools from http://download.jboss.org/jbosstools/updates/development/luna/integration-stack/earlyaccess/ 4) Create a new Wildfly 8.1.0.Final installation ( http://wildfly.org/downloads/ ) and overlay the switchyard-installer-wildfly-2.0.0.Beta1.zip ( http://switchyard.jboss.org/downloads ) 5) Create a Server configuration in my workspace for a Wildfly 8.x server 6) Start the server (seems fine up to this point) 7) Import my trusty camel-file-binding quickstart from my SwitchYard quickstarts github repo ( https://github.com/jboss-switchyard/quickstarts ) 7) Right-click on the server and Add/Remove... - I see a little red (icon missing) graphic to the left of my SwitchYard quickstart project, but it is in the list. 8) Add it and hit OK. 9) It seems to deploy ok in the server console and shows up in the server tree with the same icon missing 10) Go to http://localhost:9990/console/App.html#sy-apps to look at my running server and the deployed application does not show up 11) Try to undeploy - it will not undeploy at all.

      Description

      Issue reported in the forum. Investigated locally. Reproducible in clean Eclipse workspace as documented in reproduction steps.

        Gliffy Diagrams

          Attachments

          1. .log
            24 kB
          2. deployments.zip
            3 kB

            Issue Links

              Activity

                People

                • Assignee:
                  bfitzpat Brian Fitzpatrick
                  Reporter:
                  bfitzpat Brian Fitzpatrick
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: