Uploaded image for project: 'SwitchYard'
  1. SwitchYard
  2. SWITCHYARD-2294

Quckstarts build requires JDK 1.7 now that WildFly deploy plugin is being used

    Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: quickstarts
    • Labels:
      None

      Description

      The WildFly deploy plugin requries JDK 1.7 to execute. If building on an older Java version, class version errors are thrown and the build fails.

      At this point, seeing as components and release now require JDK 1.7, perhaps it's best to set the default enforcer rules to jdk 1.7 in SwitchYard parent.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                dpalmer Douglas Palmer
                Reporter:
                rcernich Rob Cernich
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: