1. "core: core/config" should just be "core: config". Reasoning is that the configuration/model code isn't really "core" - it just lives in the core repository (which should be renamed at some point, IMHO).
2. "core: tools/maven/plugins/configurator" should be "core: tools/maven/plugins/switchyard". A single plugin has one goalPrefix, and can have multiple goals. Each goal represents a mojo, and "configurator" is just one goal/mojo. We could very well have more goals/mojos in the future, but they should be bundled together with the maven "switchyard:" goalPrefix, as one plugin. This doesn't stop us from having other plugins too, for example with a "switchyardAdmin:" prefix or similar, but that's not necessary yet. To summarize, to execute the ConfiguratorMojo as part of the switchyard plugin, you would run "mvn switchyard:configurator". This allows us to have something like "mvn switchyard:worldpeace" in the future.