JBoss Enterprise SOA Platform
  1. JBoss Enterprise SOA Platform
  2. SOA-3524

NoClassDefFoundError when deploying ESB archives through JON

    Details

    • Affects Testing:
      Regression
    • Steps to Reproduce:
      Hide

      1. Go to JBoss ESB tab in the SOA-P 5.2 server
      2. Click Inventory > Overview
      3. Click Create New: Deployment and OK
      4. Upload file (eg. Quickstart_helloworld_failing.esb) and click CREATE
      5. Go to the History of create child resource requests and see the Request Status: Failure

      Show
      1. Go to JBoss ESB tab in the SOA-P 5.2 server 2. Click Inventory > Overview 3. Click Create New: Deployment and OK 4. Upload file (eg. Quickstart_helloworld_failing.esb) and click CREATE 5. Go to the History of create child resource requests and see the Request Status: Failure
    • Similar Issues:
      Show 10 results 

      Description

      There's a NoClassDefFoundError when deploying an ESB archive (zipped and exploded) through the JON console in Request Status: Failure link:

      java.lang.reflect.UndeclaredThrowableException
      at $Proxy83.createResource(Unknown Source)
      at org.rhq.core.pc.inventory.CreateResourceRunner.call(CreateResourceRunner.java:114)
      at org.rhq.core.pc.inventory.CreateResourceRunner.run(CreateResourceRunner.java:95)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:636)
      Caused by: java.lang.Exception: java.lang.NoClassDefFoundError: org/rhq/plugins/jbossas5/deploy/RemoteDeployer
      at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:530)
      ... 5 more
      Caused by: java.lang.NoClassDefFoundError: org/rhq/plugins/jbossas5/deploy/RemoteDeployer
      at org.jbosson.plugins.jbossesb.ESB5Component.getDeployer(ESB5Component.java:240)
      at org.jbosson.plugins.jbossesb.ESB5Component.createResource(ESB5Component.java:226)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:525)
      ... 5 more
      Caused by: java.lang.ClassNotFoundException: org.rhq.plugins.jbossas5.deploy.RemoteDeployer
      at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
      at org.rhq.core.pc.plugin.PluginClassLoader.loadClass(PluginClassLoader.java:63)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
      ... 12 more

      Additional info:
      https://bugzilla.redhat.com/show_bug.cgi?id=727976

        Issue Links

          Activity

          Hide
          David Tucker
          added a comment -

          That link doesn't work anymore. Is there somewhere I can get this patch? Is it in the customer portal.

          Show
          David Tucker
          added a comment - That link doesn't work anymore. Is there somewhere I can get this patch? Is it in the customer portal.
          Hide
          Kevin Conner
          added a comment -

          The link works, you need to log on to the RH VPN to access it.

          Show
          Kevin Conner
          added a comment - The link works, you need to log on to the RH VPN to access it.
          Hide
          Robson Watt
          added a comment -

          Hi all,

          I have this problem on a production enviroment.. Please tell me how I can resolve this issue!!! Thank you.

          Regards,

          Rob

          Show
          Robson Watt
          added a comment - Hi all, I have this problem on a production enviroment.. Please tell me how I can resolve this issue!!! Thank you. Regards, Rob
          Hide
          Pavel Kralik
          added a comment -

          Hi Robson,

          the problem is solved with the latest jon-plugin-pack-soa-2.4.1.GA.zip and jon-plugin-pack-dataservices-2.4.1.GA.zip plugin packs.

          Show
          Pavel Kralik
          added a comment - Hi Robson, the problem is solved with the latest jon-plugin-pack-soa-2.4.1.GA.zip and jon-plugin-pack-dataservices-2.4.1.GA.zip plugin packs.
          Hide
          RH Bugzilla Integration
          added a comment -

          This issue has been migrated to Bugzilla bug 781038. Please note that this JIRA issue has been closed as part of the migration and therefore you will need to check the Bugzilla issue to find the current status.

          Show
          RH Bugzilla Integration
          added a comment - This issue has been migrated to Bugzilla bug 781038 . Please note that this JIRA issue has been closed as part of the migration and therefore you will need to check the Bugzilla issue to find the current status.

            People

            • Assignee:
              Tom Cunningham
              Reporter:
              Pavel Kralik
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: