JBoss Enterprise SOA Platform
  1. JBoss Enterprise SOA Platform
  2. SOA-2613

Subset of web-service related quickstarts does not work with CXF part II.

    Details

    • Type: Bug Bug
    • Status: Closed (View Workflow)
    • Priority: Critical Critical
    • Resolution: Duplicate Issue
    • Affects Version/s: 5.1.0.ER3
    • Fix Version/s: 5.1.0 GA
    • Component/s: Examples, JBossESB
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      The following QSs do not work with CXF as well:
      webservice_wsaddressing
      webservice_proxy_basic

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Kevin Conner added a comment -

            Logging has been updated in JBESB-3539, now states

            "Detected WS implementation, using CXF"

            Show
            Kevin Conner added a comment - Logging has been updated in JBESB-3539 , now states "Detected WS implementation, using CXF"
            Hide
            Kevin Conner added a comment -

            The WS-A integration works when the workaround for SOA-2553 is applied, as the ReplyTo reference property is not otherwise initialised.

            Current state is that

            • WS-A works with the SOA-2553 workaround
            • webservice_proxy_basic works as expected

            Is there something I am missing?

            Show
            Kevin Conner added a comment - The WS-A integration works when the workaround for SOA-2553 is applied, as the ReplyTo reference property is not otherwise initialised. Current state is that WS-A works with the SOA-2553 workaround webservice_proxy_basic works as expected Is there something I am missing?
            Hide
            Martin Vecera added a comment -
            • I don't know what was the problem in webservice_proxy_basic. Now it works for me as well.
            • WS-A really works with the workaround
            Show
            Martin Vecera added a comment - I don't know what was the problem in webservice_proxy_basic. Now it works for me as well. WS-A really works with the workaround
            Hide
            Martin Vecera added a comment -

            Please note, that those two files in SOA-2553 seem to be the only location of important Ant tasks like WsImport.

            Show
            Martin Vecera added a comment - Please note, that those two files in SOA-2553 seem to be the only location of important Ant tasks like WsImport.
            Hide
            RH Bugzilla Integration added a comment -

            This issue has been migrated to Bugzilla bug 780226. Please note that this JIRA issue has been closed as part of the migration and therefore you will need to check the Bugzilla issue to find the current status.

            Show
            RH Bugzilla Integration added a comment - This issue has been migrated to Bugzilla bug 780226 . Please note that this JIRA issue has been closed as part of the migration and therefore you will need to check the Bugzilla issue to find the current status.

              People

              • Assignee:
                Kevin Conner
                Reporter:
                Martin Vecera
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development