FUSE Services Framework
  1. FUSE Services Framework
  2. SF-378

exceptionMessageCauseEnabled flag is not working correctly in some cases for sending cause back to client.

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 2.4.0-fuse-00-27
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 9 results 

      Description

      exceptionMessageCauseEnabled flag is not working correctly in some cases for sending cause back to client in Soap fault. It only sends top level exception stacktrace.

        Activity

        Willem Jiang
        added a comment -

        There is min issue that the CXF doesn't return the full stack trace if the exception has the cause. I just committed a fix into Apache CXF.

        Show
        Willem Jiang
        added a comment - There is min issue that the CXF doesn't return the full stack trace if the exception has the cause. I just committed a fix into Apache CXF.
        Willem Jiang
        added a comment -

        The patch is committed into apache CXF and merged into Fuse SF repository.
        http://svn.apache.org/viewvc?rev=1182747&view=rev

        Show
        Willem Jiang
        added a comment - The patch is committed into apache CXF and merged into Fuse SF repository. http://svn.apache.org/viewvc?rev=1182747&view=rev

          People

          • Assignee:
            Willem Jiang
            Reporter:
            Ulhas Bhole
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: