Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 2.2.5-psc-01-00
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Similar Issues:
      Show 10 results 

      Description

      The re-working of the EndpointReferenceUtils schema caching logic in 2.2.5 can cause schema validation failures. See ESB-1075 for details of the testcase.

      The problem manifests as:

      SAXException for newSchema() on
      org.xml.sax.SAXParseException: src-resolve: Cannot resolve the name 'ns1:IllustrationSet' to a(n) 'type definition' component.
      

      and thereafter as:

      org.apache.cxf.interceptor.Fault: Unmarshalling Error: cvc-elt.1: Cannot find the declaration of element 'generateIllustration'. 
      

        Issue Links

          Activity

          Eoghan Glynn
          added a comment -

          The issue appears to be caused by the removal of the LSResourceResolver.resolve() logic to scan the schema-to-source map for entries corresponding to keys ending with the required namespace URI.

          Show
          Eoghan Glynn
          added a comment - The issue appears to be caused by the removal of the LSResourceResolver.resolve() logic to scan the schema-to-source map for entries corresponding to keys ending with the required namespace URI.
          Eoghan Glynn
          added a comment -

          Fix for corresponding Apache issue CXF-2609 commited to Apache trunk.

          Show
          Eoghan Glynn
          added a comment - Fix for corresponding Apache issue CXF-2609 commited to Apache trunk.
          Eoghan Glynn
          added a comment - - edited

          Fix for corresponding Apache issue CXF-2609 committed to Apache 2.2.x-fixes branch. From there, it will propagate automatically to the FUSE SF cxf-2.2.x-fuse branch.

          Show
          Eoghan Glynn
          added a comment - - edited Fix for corresponding Apache issue CXF-2609 committed to Apache 2.2.x-fixes branch. From there, it will propagate automatically to the FUSE SF cxf-2.2.x-fuse branch.

            People

            • Assignee:
              Eoghan Glynn
              Reporter:
              Eoghan Glynn
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: