Seam Faces
  1. Seam Faces
  2. SEAMFACES-187

Seam faces fails to deploy without Pretty faces on AS7

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Out of Date Out of Date
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      JBoss AS7. Indigo, M2Eclipse
    • Workaround:
      Workaround Exists
    • Workaround Description:

      Add PrettyFaces as a dependency

      Show
      Add PrettyFaces as a dependency
    • Bugzilla Update:
      Perform
    • Similar Issues:
      Show 10 results 

      Description

      When deploying a war file with only the dependency below, an error is thrown:

      <dependency>
        <groupId>org.jboss.seam.faces</groupId>
        <artifactId>seam-faces</artifactId>
        <version>3.0.2.Final</version><!--$NO-MVN-MAN-VER$ -->
      </dependency>
      
      18:59:50,935 WARN  [org.jboss.modules] (MSC service thread 1-4) Failed to define class org.jboss.seam.faces.rewrite.RewriteConfiguration in Module "deployment.exemplo-web.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/jboss/seam/faces/rewrite/RewriteConfiguration (Module "deployment.exemplo-web.war:main" from Service Module Loader)
      	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:401)
      	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261)
      	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76)
      	at org.jboss.modules.Module.loadModuleClass(Module.java:588)
      	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:183)
      	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)
      	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)
      	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)
      	at org.jboss.as.weld.WeldModuleResourceLoader.classForName(WeldModuleResourceLoader.java:68) [jboss-as-weld-7.0.0.Final.jar:7.0.0.Final]
      	at org.jboss.weld.bootstrap.BeanDeployer.addClass(BeanDeployer.java:83) [weld-core-1.1.2.AS7.jar:2011-07-06 12:26]
      	at org.jboss.weld.bootstrap.BeanDeployer.addClasses(BeanDeployer.java:133) [weld-core-1.1.2.AS7.jar:2011-07-06 12:26]
      	at org.jboss.weld.bootstrap.BeanDeployment.createBeans(BeanDeployment.java:191) [weld-core-1.1.2.AS7.jar:2011-07-06 12:26]
      	at org.jboss.weld.bootstrap.WeldBootstrap.deployBeans(WeldBootstrap.java:368) [weld-core-1.1.2.AS7.jar:2011-07-06 12:26]
      	at org.jboss.as.weld.WeldContainer.start(WeldContainer.java:81) [jboss-as-weld-7.0.0.Final.jar:7.0.0.Final]
      	at org.jboss.as.weld.services.WeldService.start(WeldService.java:89) [jboss-as-weld-7.0.0.Final.jar:7.0.0.Final]
      	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)
      	at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_24]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_24]
      	at java.lang.Thread.run(Thread.java:662) [:1.6.0_24]
      Caused by: java.lang.NoClassDefFoundError: com/ocpsoft/pretty/faces/spi/ConfigurationProvider
      	at java.lang.ClassLoader.defineClass1(Native Method) [:1.6.0_24]
      	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632) [:1.6.0_24]
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:616) [:1.6.0_24]
      	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [:1.6.0_24]
      	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:397)
      	... 19 more
      Caused by: java.lang.ClassNotFoundException: com.ocpsoft.pretty.faces.spi.ConfigurationProvider from [Module "deployment.exemplo-web.war:main" from Service Module Loader]
      	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:191)
      	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)
      	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:330)
      	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:330)
      	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)
      	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)
      	... 24 more
      

      I believe this is due to having a class extending a Pretty faces class that is not on my lib, but that shouldn´t be required

        Issue Links

          Activity

          George Gastaldi
          added a comment -

          According to bleathem, this is caused by a overzealous classpath scanner in AS7. There may be already an issue about that. This issue must be linked to the original issue and closed as a duplicate.

          Show
          George Gastaldi
          added a comment - According to bleathem, this is caused by a overzealous classpath scanner in AS7. There may be already an issue about that. This issue must be linked to the original issue and closed as a duplicate.
          Brian Leathem
          added a comment -

          The issue, as described by Dan Allen w.r.t. Glassfsih 3.1:
          http://seamframework.org/Seam3/CompatibilityHome#H-OverzealousClassScanner

          Show
          Brian Leathem
          added a comment - The issue, as described by Dan Allen w.r.t. Glassfsih 3.1: http://seamframework.org/Seam3/CompatibilityHome#H-OverzealousClassScanner
          Marek Schmidt
          added a comment -

          AS7 issue (AS7-290), seems to be fixed in recent AS7 builds.

          Show
          Marek Schmidt
          added a comment - AS7 issue ( AS7-290 ), seems to be fixed in recent AS7 builds.
          Gerry Matte
          added a comment -

          I just encountered this issue on 7.1.0.Final + Seam 3.1.0.Final using example security-idmconsole.

          Show
          Gerry Matte
          added a comment - I just encountered this issue on 7.1.0.Final + Seam 3.1.0.Final using example security-idmconsole.
          Karsten Wutzke
          added a comment - - edited

          I also have this CNFE when using JBoss AS 7.1.1.Final + Seam 3.1.0.Final - please fix/reopen

          Show
          Karsten Wutzke
          added a comment - - edited I also have this CNFE when using JBoss AS 7.1.1.Final + Seam 3.1.0.Final - please fix/reopen
          RH Bugzilla Integration
          added a comment -

          Marek Novotny <mnovotny@redhat.com> made a comment on bug 815832

          Seam 3 is not in any way tested, supported on EAP6 JBoss AS. This issue will be rejected

          Show
          RH Bugzilla Integration
          added a comment - Marek Novotny <mnovotny@redhat.com> made a comment on bug 815832 Seam 3 is not in any way tested, supported on EAP6 JBoss AS. This issue will be rejected
          RH Bugzilla Integration
          added a comment -

          Marek Novotny <mnovotny@redhat.com> changed the Status of bug 815832 from NEW to CLOSED

          Show
          RH Bugzilla Integration
          added a comment - Marek Novotny <mnovotny@redhat.com> changed the Status of bug 815832 from NEW to CLOSED

            People

            • Assignee:
              Unassigned
              Reporter:
              George Gastaldi
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: