Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.1.0.Final
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Affects:
      Compatibility/Configuration
    • Workaround:
      Workaround Exists
    • Workaround Description:

      It appears the beans are not resolved across BDAs in the WEB-INF/lib.

      As per the injection-point inside "MessagesAdapter" of seam-faces module, it needs a "Messages" bean from seam-international module, and it wasn't accessible. I created an uber jar out of the seam-faces and seam-international module and it worked.

      Show
      It appears the beans are not resolved across BDAs in the WEB-INF/lib. As per the injection-point inside "MessagesAdapter" of seam-faces module, it needs a "Messages" bean from seam-international module, and it wasn't accessible. I created an uber jar out of the seam-faces and seam-international module and it worked.
    • Steps to Reproduce:

      1) Create a JEE6 application using Maven
      2) If deploying in eclipse, make sure "Deploy as exploded archive" is marked in Server properties -> Publishing
      3) The error occurs when bootstraping the application

      Show
      1) Create a JEE6 application using Maven 2) If deploying in eclipse, make sure "Deploy as exploded archive" is marked in Server properties -> Publishing 3) The error occurs when bootstraping the application
    • Similar Issues:
      Show 10 results 

      Description

      I am using Weblogic12c that seems to bundle Weld(1-1-3.SP1) as a CDI container.And that I am trying to deploy a simple seam-faces(3.1.0.Final) app, which fails with following unsatisfied-dependencies during the deployment.

      Caused By: org.jboss.weld.exceptions.DeploymentException: WELD-001408 Unsatisfied dependencies for type [Messages] with qualifiers [@Default] at injection point [[parameter 2] of [method] org.jboss.seam.faces.status.MessagesAdapter.convert(PhaseEvent, Messages)]
              at org.jboss.weld.bootstrap.Validator.validateInjectionPoint(Validator.java:274)
              at org.jboss.weld.bootstrap.Validator.validateInjectionPoint(Validator.java:243)
              at org.jboss.weld.bootstrap.Validator.validateObserverMethods(Validator.java:505)
              at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:335)
              at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:366)
      
      1. pom.xml
        2 kB
        George Gastaldi

        Activity

        George Gastaldi
        added a comment -

        We should have a pom.xml with a <relocation> info:

        http://maven.apache.org/ref/3.0.4/maven-model/maven.html#class_relocation

        Show
        George Gastaldi
        added a comment - We should have a pom.xml with a <relocation> info: http://maven.apache.org/ref/3.0.4/maven-model/maven.html#class_relocation
        George Gastaldi
        added a comment -

        What's the current status on this ?

        Show
        George Gastaldi
        added a comment - What's the current status on this ?
        Joseph Snyder
        added a comment -

        I fixed this Febrary. I believe that if you apply the CDI-related patches to WLS then it works fine. I'm pretty sure the patch you want is:
        Patch Name: 13945990
        Description: SU Patch [27QT]: MERGE REQUEST ON TOP OF 12.1.1.0.0 FOR BUGS 13893259 13940337 (Patch)

        Show
        Joseph Snyder
        added a comment - I fixed this Febrary. I believe that if you apply the CDI-related patches to WLS then it works fine. I'm pretty sure the patch you want is: Patch Name: 13945990 Description: SU Patch [27QT] : MERGE REQUEST ON TOP OF 12.1.1.0.0 FOR BUGS 13893259 13940337 (Patch)
        Joseph Snyder
        added a comment -

        I fixed this in February!

        Show
        Joseph Snyder
        added a comment - I fixed this in February!
        George Gastaldi
        added a comment -

        Closing this issue

        Show
        George Gastaldi
        added a comment - Closing this issue

          People

          • Assignee:
            Unassigned
            Reporter:
            George Gastaldi
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: