Uploaded image for project: 'Red Hat Decision Manager'
  1. Red Hat Decision Manager
  2. RHDM-382

Loading popup displayed indefinitely after deleting project

    Details

    • Affects Build:
      RC3
    • Target Release:
    • Fix Build:
      CR1
    • Steps to Reproduce:
      Hide

      I can reproduce this 100% with RHDM 7.0 CR3(based on 7.5.x community) using the following steps to reproduce (see video)
      1. Login to decision-central
      2. Go to Projects > Try samples > optacloud > ok
      3. wait a few seconds for assets to be indexed
      4. Settings > Delete project

      Expected results - I'm back to empty project list
      Actual resut: Popup "Loading assets" displayed indefinitely (clicking anything is blocked while the popup is displayed, so the only way to get back to work is browser refresh).

      Show
      I can reproduce this 100% with RHDM 7.0 CR3 (based on 7.5.x community) using the following steps to reproduce (see video) 1. Login to decision-central 2. Go to Projects > Try samples > optacloud > ok 3. wait a few seconds for assets to be indexed 4. Settings > Delete project Expected results - I'm back to empty project list Actual resut: Popup "Loading assets" displayed indefinitely (clicking anything is blocked while the popup is displayed, so the only way to get back to work is browser refresh).
    • Affects:
      Release Notes
    • Release Notes Text:
      Hide
      Please document the issue and two workarounds, gist if the issue is below, please refine for release notes text.
      Anyone deleting a nonempty project will encounter this issue. Since
      the popup blocks all mouse clicks, the only recovery is to refresh the
      browser window. I don't think there is any good way to avoid this
      without the fix (you might be able to avoid this by deleting all
      assets before deleting a project).
      Show
      Please document the issue and two workarounds, gist if the issue is below, please refine for release notes text. Anyone deleting a nonempty project will encounter this issue. Since the popup blocks all mouse clicks, the only recovery is to refresh the browser window. I don't think there is any good way to avoid this without the fix (you might be able to avoid this by deleting all assets before deleting a project).

      Description

      Popup "Loading assets" is displayed indefinitely every time after I delete a project.
      This popup also appears randomly on Project List while assets are being indexed (and doesn't disappear even after asset indexing finishes).

      Max Barkley I'm assigning this to you because I saw you fixed ERRAI-1095 which seems kind of related. Feel free to reassign.

      EDIT: Investigating this a bit more it seems like closing the busy indicator is not done properly in ProjectScreen - shouldn't we use HasBusyIndicatorDefaultErrorCallback there to ensure proper closing of popup even when error occurs?

      EDIT2: similar issue with indefinitely displayed loading popup (also a regression since CR2 build) happens e.g. when you click "Build & deploy" and while build operation is in progress, click "Spaces" breadcrumb. You'll get the popup "Building" displayed indefinitely.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  mbarkley Max Barkley
                  Reporter:
                  jhrcek Jan Hrcek
                  Tester:
                  Jan Hrcek
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: