Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-901

Panel Menu Item : reRender doesn't work

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.1, 3.2.0
    • Component/s: None
    • Labels:
      None

      Description

      richfaces-demo project
      panelMenu example

      if I replace outputPanel usage to simple reRender - ajax-update-ids will be empty after responce returned.

        Gliffy Diagrams

          Activity

          maksimkaszynski Maksim Kaszynski added a comment -

          Should add regions

          sergeyhalipov Sergey Halipov added a comment -

          Revision 2961.

          ilya_shaikovsky Ilya Shaikovsky added a comment -

          Check on 3.1.1 one more time.

          sergeyhalipov Sergey Halipov added a comment -

          Committed revision 3047.

          hafthalion Jaroslav Abraham added a comment -

          Has this really been fixed in 3.1.1-GA? It still doesn't work for me. I use some custom components, but doesn't work even if I modify the latest richfaces demo to use reRender on menu items without automatically rendered ajax outputPanel. The same scenario works with normal commandLinks.

          afrancuzov Alexander Francuzov added a comment -

          Not able to reproduce on the latest build (10/09/07)


            People

            • Assignee:
              afrancuzov Alexander Francuzov
              Reporter:
              ilya_shaikovsky Ilya Shaikovsky
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development