Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-881

rich:tree - showConnectingLines problem in Firefox

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Richfaces 3.1.0-rc5
      Firefox 2.0.0.6 / Windows XP

      Description

      When showConnectingLines=false is set, the last node in each subtree has a background image rendered next to it. The URL for the image is something like: /a4j_3_1_0-SNAPSHOTorg.richfaces.renderkit.html.images.TreeLineLastImage/DATB/eAH7....1Tv3GRgYACS3BY4_.jsf.

      This issue only appears in Firefox. It looks fine with IE6.

      I have a screenshot I intend to attach.

        Gliffy Diagrams

          Activity

          Hide
          jaydfwtx Jason Young added a comment -

          Notice the background image next to the expansion icon.

          Show
          jaydfwtx Jason Young added a comment - Notice the background image next to the expansion icon.
          Hide
          ilya_shaikovsky Ilya Shaikovsky added a comment -

          make sure it works under 3.1.1

          Show
          ilya_shaikovsky Ilya Shaikovsky added a comment - make sure it works under 3.1.1
          Hide
          nbelaevski Nick Belaevski added a comment -

          Fix reverted in r3298 as it broken connecting lines functionality in FF/ajax

          Show
          nbelaevski Nick Belaevski added a comment - Fix reverted in r3298 as it broken connecting lines functionality in FF/ajax

            People

            • Assignee:
              afrancuzov Alexander Francuzov
              Reporter:
              jaydfwtx Jason Young
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development