Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-851

"<%%%>" string value processed wrong with Tidy Filter

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.3, 3.2.0
    • Component/s: None
    • Labels:
      None

      Description

      <h:form>
      <h:dataTable value="#

      {capitalsBean.capitals}

      " var="cap" rows="20" border="1" id="table">
      <h:column>
      <h:inputText value="#

      {cap.name}" rendered="#{cap.checked}"></h:inputText>
      <h:outputText value="#{cap.name}

      " rendered="#

      {not cap.checked}"></h:outputText>
      </h:column>
      <h:column>
      <h:inputText value="#{cap.state}" rendered="#{cap.checked}"></h:inputText>
      <h:outputText value="#{cap.state}" rendered="#{not cap.checked}

      "></h:outputText>
      </h:column>
      <h:column>
      <h:selectBooleanCheckbox value="#

      {cap.checked}

      ">
      <a4j:support event="onclick" reRender="table"></a4j:support>
      </h:selectBooleanCheckbox>
      </h:column>
      </h:dataTable>
      </h:form>
      1) Check the check box to make line editable,
      2) paste <%%%> to any edit
      3) uncheck the box to submit this
      4) try to check again

      After WriteAttribute writes this value to input's value attribute it escaped all symbols Ok. But after Tydy process the page it use still "<%%%>" and Parse error appears.

      Works fine under FastFilter

        Gliffy Diagrams

          Activity

          alexsmirnov Alexander Smirnov added a comment -

          Can't reproduce - In a my sample, Tidy filter escape attributes as :
          <input id="j_id3:input" type="text" name="j_id3:input" value="< % % % >"

          alexsmirnov Alexander Smirnov added a comment -

          Removed special instructions ( ASP, PHP etc ) for a attributes values.


            People

            • Assignee:
              ayanul Aleksej Yanul
              Reporter:
              ilya_shaikovsky Ilya Shaikovsky
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development