Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-8468

"eventsQueue" attribute of a4j:form doesn't work

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 3.3.3.CR1, 3.3.3.Final
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      RichFaces 3.3.3.CR1 / 3.3.3.Final
      Seam: 2.1.1.GA
      Windows XP
      Firefox 3.6.3

      Description

      "eventsQueue" attribute of a4j:form doesn't work, ajax requests aren't queued.

      1) Click "TEST" button
      2) Wait ~1 sec
      3) Click "TEST" button once more

      Expected result: ajax requests must be queued and processed one-by-one

      Actual result: ajax requests aren't queued, as result exception occurs: javax.servlet.ServletException: org.jboss.seam.core.LockTimeoutException: could not acquire lock on @Synchronized component: testBean

      ========== JSF view code

      <a4j:form eventsQueue="TestQueue">
      <a4j:commandButton value="TEST" action="#

      {testBean.test}

      " />
      </a4j:form>

      ========== Java bean code

      @Name("testBean")
      @Scope(ScopeType.SESSION)
      public class TestBean {
      public void test() throws InterruptedException

      { Thread.sleep(60000); }

      }

      ==========

        Gliffy Diagrams

          Activity

          nbelaevski Nick Belaevski added a comment -

          Not a bug:

          Form's "eventsQueue" attribute is for setting queue when form has ajaxSubmit="true":

          <a4j:form ajaxSubmit="true" eventsQueue="Test">
          <h:commandLink value="Link 1" />
          <h:commandLink value="Link 2" />
          </a4j:form>

          Otherwise use:

          <a4j:form ajaxSubmit="true">
          <a4j:queue />

          <a4j:commandLink value="Link 1" />
          <h:commandLink value="Link 2" />
          </a4j:form>

          m.a.g Denis Petrunin added a comment -

          Thanks for clarification. I was confused because of example in "richfaces_reference.pdf"

          <a4j:form eventsQueue="fooQueue" ...>
          ...
          </a4j:form>

          I think it will be good if richfaces will report warning or error while rendering in case of inconsistent attributes: there is "eventsQueue" but "ajaxSubmit" is missed, so "eventsQueue" has no meaning in this case.

          P.S. I never use ajaxSubmit="true" because I always use "ajaxified" components like a4j:commandLink

          nbelaevski Nick Belaevski added a comment -

          This seems to be requirements case, not supported in the current implementation, reopening the issue.

          m.a.g Denis Petrunin added a comment -

          Issue can be reproduced in RF 3.3.3.Final

          amarkhel Andrey Markhel added a comment -

          Issue is outdated. Now queue haven't attribbute size

          nbelaevski Nick Belaevski added a comment -

          a4j:form won't be ported into 4.x


            People

            • Assignee:
              nbelaevski Nick Belaevski
              Reporter:
              m.a.g Denis Petrunin
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development