Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-72

h:commandLink does not work in rich:dataTable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce Bug
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP
      facelets 1.1.12
      Tomcat 5.5.12

      Description

      <rich:dataTable ... >
      <f:facet name="header">
      <rich:columnGroup>
      <h:column>
      ...
      </rich:columnGroup>
      </f:facet>
      <h:column>
      <h:commandLink action="exportDetail" value="#

      {export.id}">
      <f:setPropertyActionListener target="#{exportForm.id}" value="#{export.id}

      " />
      </h:commandLink>
      </h:column>
      </rich:dataTable>

      This does not work in 3.0.1 SNAPSHOT....
      After clicking the link the same page is reloaded.

      After switching back to 3.0.0 it worked.

      Thank you

        Gliffy Diagrams

          Activity

          sergeyhalipov Sergey Halipov added a comment -

          Can't reproduce on the latest snapshot..

          <data:dataTable id="master" var="master" value="#

          {data.mounths}

          "
          styleClass="table" captionClass="caption" rowClasses="rowa,rowb,rowc rowcc"
          headerClass="header" footerClass="footer">
          ......
          <data:column id="mounth" styleClass="column" colspan="2"
          headerClass="cheader" footerClass="cfooter" >
          ...........
          <h:commandLink action="#

          {skinBean.change}" value="in table action" />
          </data:column>

          <data:column>
          <data:subTable id="detail" var="detail" value="#{master.detail}">
          <data:column id="name">
          ........
          <h:commandLink action="#{skinBean.change}

          " value="in subtable action" />
          </data:column>
          .........
          </data:subTable>
          </data:column>


            People

            • Assignee:
              afrancuzov Alexander Francuzov
              Reporter:
              flow1986 Florian
            • Votes:
              3 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development