Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-5

The content of the rich components is not rendered if particular components are direct children

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      facelets
    • Workaround:
      Workaround Exists
    • Workaround Description:

      using some wrapper such as h:panelGrid for content with block layout or h:panelGroup for non-block elements

      Show
      using some wrapper such as h:panelGrid for content with block layout or h:panelGroup for non-block elements
    • Estimated Difficulty:
      Medium

      Gliffy Diagrams

        Activity

        SergeySmirnov Sergey Smirnov added a comment -

        so, h:form, a4j:include, ui: decode does not work inside the rich:panel and rich:modalPanel

        see:
        http://jboss.com/index.html?module=bb&op=viewtopic&t=103348
        http://jboss.com/index.html?module=bb&op=viewtopic&t=103677

        At the same time, if set getRendersChildren to false, the problem is gone

        i.e.
        public boolean getRendersChildren()

        { return false; }

        looks like a quick fix.

        I have tested it inside the Ajax zone, the panel also works fine.

        So, what was the motivation to set getRendersChildren to true

        alexsmirnov Alexander Smirnov added a comment -

        Problem in Templates compiler. Generated code expect template method doEncodeChildren, intead of override Renderer#encodeChildren(FacesContext,UIComponent)


          People

          • Assignee:
            afrancuzov Alexander Francuzov
            Reporter:
            SergeySmirnov Sergey Smirnov
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development