Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-37

dataTable is re-rendered incorrect when the records are deleted

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.1
    • Component/s: None
    • Labels:
      None

      Gliffy Diagrams

        Activity

        nbelaevski Nick Belaevski added a comment -

        Couldn't reproduce. Screen capture attached

        legga Oleg Timoshenko added a comment -

        A sample *.war that demonstrates the bug with RichFaces 3.0.1 and MyFaces 1.1.5.
        Deploy to JBoss, open in browser, tick rows 2 and 3 and press the button.

        nbelaevski Nick Belaevski added a comment -

        Oleg,

        thank you! I'll see...

        nbelaevski Nick Belaevski added a comment -

        I've checked the sample app. It is based on outdated snapshots of RichFaces & Ajax4JSF. I've found out that the problem is fixed by replacing ajax4jsf-1.1.1-SNAPSHOT.jar with the latest version. We've introduced some changes there and the bug seems to be resolved.

        We've also added workaround for commons-collections 2.x iterator chain bug to trunk.

        Please check if the problem can still be seen on latest ajax4jsf & richfaces snapshots!

        nbelaevski Nick Belaevski added a comment -

        The issue should be considered fixed. Please reopen if not.


          People

          • Assignee:
            afrancuzov Alexander Francuzov
            Reporter:
            SergeySmirnov Sergey Smirnov
          • Votes:
            5 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development