Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-1577

listShuttle: add onitemsmove and onitemsmoved events handlers to listShuttle

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.1.3
    • Fix Version/s: 3.1.3, 3.2.0
    • Component/s: None
    • Labels:
      None
    • Affects:
      Interactive Demo/Tutorial

      Description

      should be fired before and after the item or set of items moved between lists.

      First event should be cancelable.
      Simple usecase for the second - use ajax request via support to apply changes to model.

        Gliffy Diagrams

          Activity

          vmolotkov Vladimir Molotkov added a comment -

          "onlistchanged" event is made.
          it is equivalent to onitemsmove

          viktor_volkov Viktor Volkov added a comment -

          verified on rc4

          wbarquero Will Barquero added a comment -

          Instead of "onlistchanged", or in addition to, we should have two separate events... "onsourcelistchanged" and "ontargetlistchanged". As it is now, the "onlistchanged" event is called twice because if you move an item from the source list to the item list, both lists have changed.

          ilya_shaikovsky Ilya Shaikovsky added a comment -

          As it is now, the "onlistchanged" event is called twice because if you move an item from the source list to the item list, both lists have changed.

          Can not reproduce. Open richfaces-demo (doesn't matters 3.2.2 or 3.3.0) and check in firebug that one request sent using support for this event.


            People

            • Assignee:
              viktor_volkov Viktor Volkov
              Reporter:
              ilya_shaikovsky Ilya Shaikovsky
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development