Details

    • Type: Component Upgrade
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.5.10
    • Fix Version/s: 4.5.11
    • Component/s: tests - functional
    • Labels:
      None
    • Environment:

      RichFaces 4.5.11-SNAPSHOT

      Description

      Upgrade testing dependencies to latest stable versions:

      • Arquillian Core 1.1.8.Final -> 1.1.10.Final
      • Shrinkwrap 1.2.2 -> 1.2.3
      • Shrinkwrap Descriptors 2.0.0-alpha-7 -> 2.0.0-alpha-8
      • Shrinkwrap Resolver 2.2.0-beta-1 -> 2.2.0
      • Selenium 2.46.0 -> 2.48.2 (2.46.0 api used in page-fragments, so the unit tests can run with jdk 6)
      • xmlunit 1.2 -> 1.6
      • htmlunit 2.15 -> 2.18 (2.15 is the latest version working with jdk 6)
      • htmlunit-core-js 2.15 -> 2.17
      • arquillian-drone-bom 2.0.0.Alpha4 -> 2.0.0.Alpha5
      • graphene-webdriver 2.1.0.Alpha2 -> 2.1.0.Alpha3
      • httpclient 4.3.3 -> 4.5.1 (left the same to be compatible with htmlunit)

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                jstefek Jiří Štefek
                Reporter:
                ppitonak Pavol Pitoňák
                Tester:
                Jiří Štefek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: