Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-14072

push: sometimes not properly initialized on page load

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: component-a4j-core
    • Labels:
      None

      Description

      Sometimes the push component is not initialized properly and is not working on page load.

      Could be reproduced by running integration tests from core/ with

      mvn clean verify -Dbrowser=phantomjs -Dintegration=wildfly82 -Dtest=*push.* -DskipTests

      Every time the push is not working, there is an warning on the server side:

      15:15:57,811 WARNING [javax.enterprise.resource.webcontainer.jsf.context] (default task-33) JSF1091: No mime type could be found for file org.richfaces/RES_NOT_FOUND.  To resolve this, add a mime-type mapping to the applications web.xml.
      15:15:57,815 WARNING [javax.enterprise.resource.webcontainer.jsf.application] (default task-33) JSF1064: Unable to find or serve resource, org.richfaces/RES_NOT_FOUND.
      

      It is hard to reproduce it manually by browsing to deployed page, but it happens very often while running the integration test (reproducible also in Metamer tests).

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  michpetrov Michal Petrov
                  Reporter:
                  jstefek Jiří Štefek
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated: