Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-14061

queue: when @requestDelay=0 then response is delayed by one request

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 4.5.6
    • Fix Version/s: None
    • Component/s: component-a4j-core
    • Labels:
      None
    • Environment:

      Tried with:
      RF 4.5.6, 4.5.2
      Tomcat 8
      Metamer
      FF 38, Chrome 43

    • Steps to Reproduce:
      Hide
      1. deploy Metamer and open http://localhost:8080/metamer/faces/components/a4jQueue/globalQueue.xhtml (could be also reproduced with other queue or attachQueue samples)
      2. set @requestDelay to 0
      3. type '1', '2' to the input (with label 'Type here:')
      • expected: Repeated text output contains '12'
      • have: Repeated text output contains only '1'

      Setting @requestDelay to something else than 0, e.g. 1 or even a negative number, will lead to expected behaviour.

      Show
      deploy Metamer and open http://localhost:8080/metamer/faces/components/a4jQueue/globalQueue.xhtml (could be also reproduced with other queue or attachQueue samples) set @requestDelay to 0 type '1', '2' to the input (with label 'Type here:') expected: Repeated text output contains '12' have: Repeated text output contains only '1' Setting @requestDelay to something else than 0, e.g. 1 or even a negative number, will lead to expected behaviour.

      Gliffy Diagrams

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jstefek Jiří Štefek
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: