Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-13904

RF can be deployed to Mojarra < 2.1.28

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.5.0.Final
    • Fix Version/s: 4.5.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      RichFaces 4.5.1-SNAPSHOT
      Metamer 4.5.1-SNAPSHOT
      Mojarra 2.1.7-jbossorg-1
      JBoss AS 7.1.1.Final
      Java(TM) SE Runtime Environment 1.7.0_25-b15 @ Linux
      Firefox 31.0 @ Linux x86_64

      Description

      I am capable of deploying RF app to unpatched Mojarra - e.g. version < 2.1.28.

      As described in RF-13665 this should not be possible. I tried this with Metamer and JBoss AS 7.1 + EAP 6.1.0.GA.

      We already have a code in place which should detect this and throw exception but it doesn't seem to work - link to GitHub

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                michpetrov Michal Petrov
                Reporter:
                manovotn Matěj Novotný
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: