Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-1363

suggestion box onselect not calling method

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.1.3
    • Fix Version/s: 3.1.3, 3.2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      JBOSS 4.2.0GA
      RF 3.1.3 SNAPSHOT

      Description

      onSelect does not call mathod in backing bean

      <t:inputText value="#

      {traziObrj.naziv}" size="10"
      id="SBTobracunskoMjesto" style="font-size: 10px;"
      onkeypress="return disableEnter(event);" onblur="this.value='';" />
      <r:suggestionbox id="SBobracunskoMjesto" requestDelay="500"
      selectedClass="selectedClassSB" for="SBTobracunskoMjesto"
      suggestionAction="#{traziObrj.autocomplete}" var="r"
      fetchValue="#{r.naziv.naziv}" minChars="2" width="400"
      height="150"
      nothingLabel="#{messages['zajednicke.nemaRezultata']}">
      <a:support event="onselect"
      action="#{obradaZaposlenik.dodajObracunskoMjesto(zaposlenik,r)}"
      reRender="obracunskoMjesto,SBTobracunskoMjesto,SBobracunskoMjesto">
      <t:updateActionListener value="" property="#{traziObrj.naziv}

      " />
      </a:support>
      <r:column width="15%">
      <t:outputText value="#

      {r.sifra}

      " />
      </r:column>
      <r:column width="85%">
      <t:outputText value="#

      {r.naziv.naziv}

      " />
      </r:column>
      </r:suggestionbox>

        Gliffy Diagrams

          Issue Links

            Activity

            akushunin Alexej added a comment -

            Tomislav, please provide more information about your problem.
            Please attach full page source or test application which allows to reproduce the issue.
            May be problem exists in #

            {obradaZaposlenik.dodajObracunskoMjesto(zaposlenik,r)}

            method.
            I can't reproduce this issue on my side.

            tjakopec Tomislav Jakopec added a comment -

            Alexej, in examples files search for

            "FOR RicFaces Alexej Kushunin"

            akushunin Alexej added a comment -

            this problem fixed for 3.2.0 version

            akushunin Alexej added a comment -

            already fixed for 3.2.0 see RF-923

            akushunin Alexej added a comment -

            merged with trunk fix.


              People

              • Assignee:
                ayanul Aleksej Yanul
                Reporter:
                tjakopec Tomislav Jakopec
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development