Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-1359

Resource xxxSeparatorImage not loaded during initialization

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.1.1
    • Fix Version/s: 3.1.3, 3.2.0
    • Component/s: None
    • Labels:
      None

      Description

      The resources xxxxSeparatorImage, (e.g. LineSeparatortImage) used by ToolBarGroupRenderer, is not specified in the META-INF/resource-config.xml file, so it doesn't get preloaded when the application starts.
      In a single-server environment this doesn't matter, because the ToolBarGroupRenderer loads it into the resource map the first time it is used to render a page.

      However in our multi-server environment we occassionally get a resource-not-found error when the request to load the image goes to a different server from the one that processed the request to load the page.

        Gliffy Diagrams

          Activity

          Hide
          abelevich Anton Belevich added a comment -

          trunk, 3.1.x

          Show
          abelevich Anton Belevich added a comment - trunk, 3.1.x

            People

            • Assignee:
              ayanul Aleksej Yanul
              Reporter:
              aballard Alan Ballard
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development