This issue addresses the cleanup of the java package namespace of the demo.
1) The package org.richfaces.photoalbum.bean contains the single class UserBean. Let's rename the package to something less generic like user or consider merging it into another pre-existing package like ui.
2) The event package is separate from the domain package. Let's consider moving the event package to be a sub-package of domain. While we are at it, I find the package name model to be more descriptive than domain.
3) The services package may be better described as an actions package.
4) The util package is too generic. Consider creating converters and validators packages to hold the bulk of these classes. Additionally the classnames *Stuff and Utils could be named less generically.
5) having the two top-level classes search and ejbsearch is confusing. Can one package be a sub-folder of the other? Alternatively could one be in the ui folder, or the other in a model folder?