Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-12669

Autocomplete: client side validation for custom validators doesn't work

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.3.0.M3
    • Fix Version/s: 4.3.0.CR1
    • Component/s: component-input, regression
    • Labels:
      None
    • Environment:

      RichFaces 4.3.0.20121214-M3
      Metamer 4.3.0.20121214-M3
      Mojarra 2.1.7
      JBoss AS 7.1.2.Final-redhat-1
      Java(TM) SE Runtime Environment 1.7.0_04-b20 @ Linux
      Chrome 23.0.1271.97 @ Linux x86_64

    • Sprint:
      4.3.0.CR1 - Regression Fixes

      Description

      1. deploy Metamer and open http://localhost:8080/metamer/faces/components/richAutocomplete/csv.xhtml
      2. click "set wrong values" button

      result:

      • 4 messages should be visible, one for each input
      • fourth input has no message
      • worked well with RF 4.3.0.M2
      • works fine with other inputs, e.g. inplaceInput

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  bleathem Brian Leathem
                  Reporter:
                  ppitonak Pavol Pitonak
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Time Tracking

                    Estimated:
                    Original Estimate - 2 hours
                    2h
                    Remaining:
                    Remaining Estimate - 2 hours
                    2h
                    Logged:
                    Time Spent - Not Specified
                    Not Specified