Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-1239

org.richfaces.component.state.TreeState cannot be de-serialized

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.1.3, 3.2.0
    • Component/s: None
    • Labels:
      None

      Description

      When holding a TreeState in a component (Seam - either session or conversation), when the session times out and the component is removed there is an exception:

      17:20:44,677 WARN [Component] Exception calling stateful session bean default @Remove method: pageT
      ree
      java.lang.RuntimeException: java.lang.RuntimeException: org.jboss.serial.exception.SerializationExce
      ption: Could not create instance of org.richfaces.component.state.TreeState - org.richfaces.componen
      t.state.TreeState
      at org.jboss.ejb3.interceptor.LifecycleInterceptorHandler.postActivate(LifecycleInterceptorH
      andler.java:152)
      at org.jboss.ejb3.stateful.StatefulContainer.invokePostActivate(StatefulContainer.java:400)
      at org.jboss.ejb3.stateful.StatefulBeanContext.postActivate(StatefulBeanContext.java:381)
      at org.jboss.ejb3.cache.simple.StatefulSessionFilePersistenceManager.activateSession(Statefu
      lSessionFilePersistenceManager.java:316)
      (...)
      Caused by: org.jboss.serial.exception.SerializationException: Could not create instance of org.richf
      aces.component.state.TreeState - org.richfaces.component.state.TreeState
      at org.jboss.serial.classmetamodel.ClassMetaData.newInstance(ClassMetaData.java:342)
      at org.jboss.serial.persister.RegularObjectPersister.readData(RegularObjectPersister.java:23
      9)
      at org.jboss.serial.objectmetamodel.ObjectDescriptorFactory.readObjectDescriptionFromStreami
      ng(ObjectDescriptorFactory.java:412)
      at
      (...)
      Caused by: java.lang.InstantiationException: org.richfaces.component.state.TreeState
      at java.lang.Class.newInstance0(Class.java:335)
      at java.lang.Class.newInstance(Class.java:303)
      at org.jboss.serial.classmetamodel.ClassMetaData.newInstance(ClassMetaData.java:334)
      ... 78 more

        Gliffy Diagrams

          Activity

          nbelaevski Nick Belaevski added a comment -

          resolved

          ilya_shaikovsky Ilya Shaikovsky added a comment -

          commit in 3.1.x branch and resolve to both versions please


            People

            • Assignee:
              ayanul Aleksej Yanul
              Reporter:
              adamw Adam Warski
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development