RichFaces
  1. RichFaces
  2. RF-12135

rich:extendedDataTable column width lost after table rerendering (partial state saving)

    Details

    • Steps to Reproduce:
      1. deploy Metamer and open http://localhost:8080/metamer/faces/components/richExtendedDataTable/rf-12135.xhtml
      2. change width of the first column
      3. click on the "render" link -> OK
      4. click on the "render" link again -> column width is reset
      Show
      deploy Metamer and open http://localhost:8080/metamer/faces/components/richExtendedDataTable/rf-12135.xhtml change width of the first column click on the "render" link -> OK click on the "render" link again -> column width is reset
    • Similar Issues:
      Show 10 results 

      Description

      Bug in rich:extendedDataTable - column width lost after table rerendering.

      Steps to reproduce:
      1) Resize a column.
      2) Rerender table 2 times.
      Column will take initial width.

      JSF Mojarra 2.1.7

      Column order does not have this issue. And no issue when disabling partial state saving (javax.faces.PARTIAL_STATE_SAVING).

        Gliffy Diagrams

          Activity

          Jan Papousek added a comment -

          Nick: Thank you for reporting!

          I'll add a new sample to Metamer to reproduce this issue.

          Nick Dev added a comment -

          Thanks. In ExtendedDataTableRenderer#doDecode I see that column attribute updated on resize while table attribute updated on column reorder.
          We have custom table component based on rich:extendedDataTable.
          Please let me know when this issue is resolved so that we can integrate it in our code.

          Jan Papousek added a comment -

          Added sample to Metamer and updated "Steps to Reproduce".

          Lukáš Fryč added a comment -

          I would like to cover this with JSFUnit.NG test first.

          Lukáš Fryč added a comment -

          The pull request [1] was rejected, since it had broken children visiting.

          [1] https://github.com/richfaces/components/pull/32

          Jan Papousek added a comment -

          The same problem is when rich:dataScroller is used.

          Brian Leathem added a comment -

          This issue has been resolved by other EDT fixes with the RichFaces 4.3.0.CR1 release.

          Brian Leathem added a comment -

          Pavol Pitonak please have your QE team verify that this is indeed resolved with 4.3.0.CR1/2

          Jan Papousek added a comment -

          verified on JBoss AS 7.1.1 and Apache Tomcat 7.0.34 (with Mojarra)

          RH Bugzilla Integration added a comment -

          Rodney Russ <rruss@redhat.com> changed the Status of bug 906791 from NEW to ON_QA

          RH Bugzilla Integration added a comment -

          Pavol Pitonak <ppitonak@redhat.com> changed the Status of bug 906791 from ON_QA to VERIFIED

          RH Bugzilla Integration added a comment -

          Pavol Pitonak <ppitonak@redhat.com> made a comment on bug 906791

          Verified in 2.2.0.ER2

          RH Bugzilla Integration added a comment -

          Karel Piwko <kpiwko@redhat.com> made a comment on bug 906791

          Closed as CURRENTRELEASE, part of WFK 2.2.0 distributables.

          RH Bugzilla Integration added a comment -

          Karel Piwko <kpiwko@redhat.com> changed the Status of bug 906791 from VERIFIED to CLOSED


            People

            • Assignee:
              Jan Papousek
              Reporter:
              Nick Dev
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development