Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-1061

Internal browser error in XMLHttpRequest caused empty page to display.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Out of Date
    • Affects Version/s: None
    • Fix Version/s: 3.2.0
    • Component/s: None
    • Labels:
      None

      Description

      In case of the internal errors ( like network connection problem or page unload ) , XMLHttpRequest object have empty content.
      Default error processing did't check empty content. As a result, empty page displayed.

        Gliffy Diagrams

          Activity

          alexsmirnov Alexander Smirnov added a comment -

          Check for a empty response added to default error handler.

          viktor_volkov Viktor Volkov added a comment -

          1. Start Tomcat
          2. Open test-application
          3. Open tree
          4. While opening tree stop Tomcat
          5. Reload page
          6. Click Retry on request
          --->>> Empty page displayed without any error

          ilya_shaikovsky Ilya Shaikovsky added a comment -

          Victor be carefull with the "Open test aplication". Did you sure that Alex know what are you told about?

          Create attachments or point to SVN link if the project are public available.

          nbelaevski Nick Belaevski added a comment -

          Please check that the issue is still actual and add new reproducing steps. Tree example seem to not show the problem


            People

            • Assignee:
              viktor_volkov Viktor Volkov
              Reporter:
              alexsmirnov Alexander Smirnov
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development