Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-10128

File upload doesn't work with MyFaces

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Out of Date
    • Affects Version/s: 4.0.0.Milestone5
    • Fix Version/s: None
    • Component/s: component-input
    • Labels:
    • Environment:

      RichFaces 4.0.0.20101226-M5 r.20800
      Metamer 4.0.0.20110104-M5 r.20882
      Apache MyFaces JSF-2.0 Core Impl 2.0.2
      Apache Tomcat 6.0.29
      OpenJDK Runtime Environment 1.6.0_20-b20 @Linux
      Chrome 8.0.552.224 @ Linux x86_64

    • Sprint:
      Sprint - Critical bug fixes
    • Story Points:
      10
    • Affects:
      Documentation (Ref Guide, User Guide, etc.)

      Description

      1. deploy Metamer
      2. open http://localhost:8080/metamer/faces/components/richFileUpload/simple.xhtml
      3. select some file
      4. click Upload

      result:
      nothing is uploaded, no other files can be uploaded

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            nbelaevski Nick Belaevski added a comment -

            Need to have at least MyFaces 2.0.5 for this to work. Added a workaround for MyFaces 2.0.5: https://issues.apache.org/jira/browse/MYFACES-3043?focusedCommentId=13022801&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13022801; MyFaces 2.0.6 should work fine with that.

            Show
            nbelaevski Nick Belaevski added a comment - Need to have at least MyFaces 2.0.5 for this to work. Added a workaround for MyFaces 2.0.5: https://issues.apache.org/jira/browse/MYFACES-3043?focusedCommentId=13022801&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13022801 ; MyFaces 2.0.6 should work fine with that.
            Hide
            bleathem Brian Leathem added a comment -

            Targeting MyFaces compatibility with 4.3.0.M1

            Show
            bleathem Brian Leathem added a comment - Targeting MyFaces compatibility with 4.3.0.M1
            Hide
            kwutzke Karsten Wutzke added a comment -

            I'm facing https://issues.jboss.org/browse/RF-11592 without any MyFaces stuff.

            Show
            kwutzke Karsten Wutzke added a comment - I'm facing https://issues.jboss.org/browse/RF-11592 without any MyFaces stuff.
            Hide
            ppitonak Pavol Pitonak added a comment -

            works for me in this environment:

            RichFaces 4.2.2.Final
            Metamer 4.2.2.20120528-Final
            Apache MyFaces JSF-2.1 Core Impl 2.1.5
            Apache Tomcat 7.0.26
            Java(TM) SE Runtime Environment 1.6.0_32-b05 @ Linux
            Chrome 19.0.1084.52 @ Linux i686

            Show
            ppitonak Pavol Pitonak added a comment - works for me in this environment: RichFaces 4.2.2.Final Metamer 4.2.2.20120528-Final Apache MyFaces JSF-2.1 Core Impl 2.1.5 Apache Tomcat 7.0.26 Java(TM) SE Runtime Environment 1.6.0_32-b05 @ Linux Chrome 19.0.1084.52 @ Linux i686
            Hide
            bleathem Brian Leathem added a comment -

            Works with recent versions of MyFaces.

            Show
            bleathem Brian Leathem added a comment - Works with recent versions of MyFaces.

              People

              • Assignee:
                ppitonak Pavol Pitonak
                Reporter:
                ppitonak Pavol Pitonak
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development

                    Agile