Uploaded image for project: 'RichFaces'
  1. RichFaces
  2. RF-10115

Command button: wrong markup when attribute type is not set

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.0.0.Milestone5
    • Fix Version/s: 4.0.0.Milestone6
    • Component/s: component-a4j-core
    • Labels:
      None
    • Environment:

      RichFaces 4.0.0.20101226-M5 r.20800
      Metamer 4.0.0.20101226-M5 r.20866
      Mojarra 2.0.3-b05
      JBoss AS 6.0.0.Final
      OpenJDK Runtime Environment 1.6.0_20-b20 @ Linux
      Chrome 8.0.552.224 @ Linux x86_64

      Description

      1. deploy Metamer to JBoss 6.0.0.Final
      2. open http://localhost:8080/metamer/faces/components/a4jCommandButton/simple.xhtml
      3. set disabled=true

      result:
      button is rendered with type="" but it should be type="submit" (default value when type is not set)

      <input id="form:a4jCommandButton" name="form:a4jCommandButton" onclick="return false;" value="command button" disabled="disabled" type="" />

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                nbelaevski Nick Belaevski
                Reporter:
                ppitonak Pavol Pitoňák
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: