Railo
  1. Railo
  2. RAILO-612

CFTHREAD type="task" timeout not working correctly?

    Details

    • Type: Bug Bug
    • Status: Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.1 Final (3.1.2.001)
    • Fix Version/s: 3.1.2.009
    • Security Level: Public (Everyone can see)
    • Labels:
      None
    • Environment:
      Windows Server 2003
    • Similar Issues:
      Show 10 results 

      Description

      When triggering a new task via CFHTREAD, my tasks keep timing out. I've added a very long timeout (10 minutes) but tasks are failing withing 50 seconds (which is the same as the request Timeout on the page)

      I think I've been able to get around this with <cfsetting RequestTimeout="6000"> inside of the <cfthread> tags. This appears to work on the first run of the task. But, if the task fails for some reason then it's impossible to restart from the administrator – it runs in to the same timeout issue described above.

      Is this not working correctly? Or, is there a simple solution for this problem?

        Activity

        Hide
        Michael Offner added a comment -

        tnx for input

        Show
        Michael Offner added a comment - tnx for input
        Hide
        Ben Pate added a comment -

        Awesome! Thank you! Railo is a fantastic product. You should be very proud.

        Show
        Ben Pate added a comment - Awesome! Thank you! Railo is a fantastic product. You should be very proud.

          People

          • Assignee:
            Michael Offner
            Reporter:
            Ben Pate
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development