Uploaded image for project: 'PicketLink'
  1. PicketLink
  2. PLINK-48

Deprecated commons-logging, trove dependencies preventing build of PicketLink

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: PLINK_2.0.0.CR1
    • Fix Version/s: None
    • Component/s: SAML
    • Labels:
      None
    • Environment:

      Maven 3.0.3, Ubuntu Linux 10.04, JDK 1.6

      Description

      In parent/pom.xml of picketlink federation trunk, the dependency for commons-logging needs to have its group ID changed from apache-logging to commons-logging, this is very similar to the fix in PLINK-47. Also, in the same pom, the following dependency needs to be added:

      <dependency>
      <groupId>trove</groupId>
      <artifactId>trove</artifactId>
      <version>1.0.2</version>
      </dependency>

      This is because the picketlink-bindings-jboss module otherwise tries to download the deprecated 2.1.1 version of trove (see here: http://community.jboss.org/wiki/JBossDeprecatedRepository for its listing as a deprecated module as well as its recommended 1.0.2 replacement.)

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                anil.saldhana Anil Saldanha
                Reporter:
                mazzag Glen Mazza
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: