Uploaded image for project: 'Portlet Bridge'
  1. Portlet Bridge
  2. PBR-460

Metamer (portlet): rich:functions: isUserInRole example doesn't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 3.1.0.CR1
    • Fix Version/s: None
    • Component/s: RichFaces
    • Labels:
      None
    • Environment:
    • Steps to Reproduce:
      Hide

      1. open Rich -> Rich Functions -> All
      2. set "admin" to "Role name" labeled input
      3. click "Apply role name"
      4. in list bottom should in first two row appears value true, but remain "false" for all. Value for "rich:isUserInRole('admin') " is false even it has to be true.

      Show
      1. open Rich -> Rich Functions -> All 2. set "admin" to "Role name" labeled input 3. click "Apply role name" 4. in list bottom should in first two row appears value true, but remain "false" for all. Value for "rich:isUserInRole('admin') " is false even it has to be true.

      Description

      Seems that isUserInRole function doesn't return true even appropriate role was set.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                kenfinni Ken Finnigan
                Reporter:
                jjamrich Ján Jamrich
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1 day
                  1d
                  Remaining:
                  Remaining Estimate - 1 day
                  1d
                  Logged:
                  Time Spent - Not Specified
                  Not Specified