jboss.org
  1. jboss.org
  2. ORG-1614

JIRA notifications not arriving for all projects

    Details

    • Similar Issues:
      Show 9 results 

      Description

      Some projects are not delivering JIRA webhook notifications. I've noticed this on XNIO for sure, but I think there may be others (REM3 perhaps?).

        Issue Links

          Activity

          Hide
          David Lloyd
          added a comment -

          Ah. Perhaps it's only projects which are not in any particular category (not sure about this JQL but in SQL, you often have to test for null explicitly in addition).

          Show
          David Lloyd
          added a comment - Ah. Perhaps it's only projects which are not in any particular category (not sure about this JQL but in SQL, you often have to test for null explicitly in addition).
          Hide
          Vlastimil Eliáš
          added a comment -

          this JQL is not about any categories, it's about concrete projects.
          this JQL means: issues from all projects which are not listed in brackets match it
          so all issues from all unlisted projects should be passed over webhook to you

          I don't think problem is in this JQL or in webhook setup.

          Most likely it's some bug in JIRA or some problem on networking level.

          I try to check jira log file if there is some evidence/exception from webhook code.

          Show
          Vlastimil Eliáš
          added a comment - this JQL is not about any categories, it's about concrete projects. this JQL means: issues from all projects which are not listed in brackets match it so all issues from all unlisted projects should be passed over webhook to you I don't think problem is in this JQL or in webhook setup. Most likely it's some bug in JIRA or some problem on networking level. I try to check jira log file if there is some evidence/exception from webhook code.
          Hide
          Vlastimil Eliáš
          added a comment -

          I found next error in jira log file

          2013-02-21 04:24:36,139 http-bio-8080-exec-39241 WARN jfclere 264x5253757x1 f19gom 10.33.144.3,10.5.105.5 /secure/DeleteComment.jspa [jira.plugins.webhooks.WebHookRegistrationManager] Failed to publish web-hooks for event com.atlassian.jira.event.issue.IssueEvent
          java.lang.NullPointerException: null value
            at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:204)
          

          This concrete error is from "Delete Comment" action, but maybe something similar may cause webhook problem during "Issue Create" too (I have got only limited log history available to check .

          Seems this problem is known as https://jira.atlassian.com/browse/JRA-31458 and fixed in JIRA 5.2.6 (we are on 5.2.5 now).

          I have plan to upgrade jira to latest version during next two or three weeks, so hope this issue will be fixed then.

          Show
          Vlastimil Eliáš
          added a comment - I found next error in jira log file 2013-02-21 04:24:36,139 http-bio-8080-exec-39241 WARN jfclere 264x5253757x1 f19gom 10.33.144.3,10.5.105.5 /secure/DeleteComment.jspa [jira.plugins.webhooks.WebHookRegistrationManager] Failed to publish web-hooks for event com.atlassian.jira.event.issue.IssueEvent java.lang.NullPointerException: null value at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:204) This concrete error is from "Delete Comment" action, but maybe something similar may cause webhook problem during "Issue Create" too (I have got only limited log history available to check . Seems this problem is known as https://jira.atlassian.com/browse/JRA-31458 and fixed in JIRA 5.2.6 (we are on 5.2.5 now). I have plan to upgrade jira to latest version during next two or three weeks, so hope this issue will be fixed then.
          Hide
          Vlastimil Eliáš
          added a comment -

          Hi David, new version of jira is deployed. Should you check if this problem is patched by new release or not please?

          Show
          Vlastimil Eliáš
          added a comment - Hi David, new version of jira is deployed. Should you check if this problem is patched by new release or not please?
          Hide
          David Lloyd
          added a comment -

          I created https://issues.jboss.org/browse/XNIO-193 and no notification arrived.

          Show
          David Lloyd
          added a comment - I created https://issues.jboss.org/browse/XNIO-193 and no notification arrived.
          Hide
          Vlastimil Eliáš
          added a comment -

          Hi David Lloyd, any news around this? JIRA has been upgraded to 6.x series in meantime, so is it better now?

          Show
          Vlastimil Eliáš
          added a comment - Hi David Lloyd , any news around this? JIRA has been upgraded to 6.x series in meantime, so is it better now?
          Hide
          David Lloyd
          added a comment -

          Looking at IRC history I see new notifications for XNIO and REM3. I think this might be fixed! Thanks.

          Show
          David Lloyd
          added a comment - Looking at IRC history I see new notifications for XNIO and REM3. I think this might be fixed! Thanks.
          Hide
          Vlastimil Eliáš
          added a comment -

          Great, thanks, feel free to contact me in case of any problems.

          Show
          Vlastimil Eliáš
          added a comment - Great, thanks, feel free to contact me in case of any problems.

            People

            • Assignee:
              Vlastimil Eliáš
              Reporter:
              David Lloyd
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: