FUSE Mediation Router
  1. FUSE Mediation Router
  2. MR-538

Request-response messaging over temp queues fails after no messages received from producer

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.8.0-fuse-01-06
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 9 results 

      Description

      Two bundles are set up in ServiceMix:

      • a producer (pinger) that makes a request via a Camel inOut("activemq:...") and waits for a response
      • a consumer (ponger) that pulls from that queue and responds on a temporary queue

      When no requests are received from the pinger for a period of time (around 2 minutes), any ping calls subsequently fail with an exception on the ponger.
      "Cannot publish to a deleted Destination: temp-queue://ID:..."

      To reproduce, disable the ping timer route in the pinger bundle (attached in ESB-1573), and wait.

        Activity

        Jonathan Anstey
        added a comment -

        This is likely due to MB-934, which isn't fixed in any release yet. There are instruction in that issue to try a SNAPSHOT version of AMQ that has the fix.

        Show
        Jonathan Anstey
        added a comment - This is likely due to MB-934 , which isn't fixed in any release yet. There are instruction in that issue to try a SNAPSHOT version of AMQ that has the fix.
        Claus Ibsen
        added a comment -

        The latest ESB 4.4.1 ESB release has the bug fixes. So we should try again with that release.

        Show
        Claus Ibsen
        added a comment - The latest ESB 4.4.1 ESB release has the bug fixes. So we should try again with that release.
        Jonathan Anstey
        added a comment -
        Show
        Jonathan Anstey
        added a comment - Yeah, MB-934 is fixed in ESB 4.4.1-fuse-01-06, just made public today: http://repo.fusesource.com/nexus/content/groups/public/org/apache/servicemix/apache-servicemix/4.4.1-fuse-01-06/

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Jakub Korab
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: