Uploaded image for project: 'mod_cluster'
  1. mod_cluster
  2. MODCLUSTER-221

Only 100 webapps are detected : Maxcontext doesn't seem to be read

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.0.9, 1.1.1.Final
    • Fix Version/s: 1.0.10
    • Component/s: None
    • Labels:
    • Environment:

      Description

      We're currently testing an architecture where we deploy 70 webapps in a 3-nodes cluster.
      After some times wondering why only some of the webapps were visible in the /mod_cluster-manager URL, we discovered that a Maxcontext parameter existed and was defaulting to 100.

      Then we set the Maxcontext parameter to 400, but it doesn't seem to change anything. Still only 100 webapp contexts are detected.

      I tried having a look at the C source code, but I don't see anything obvious.
      Maybe this parameter is just not read?

      Thanks a lot for your help.

        Gliffy Diagrams

          Attachments

          1. httpd.conf
            35 kB
            Baptiste MATHUS

            Issue Links

              Activity

                People

                • Assignee:
                  jfclere Jean-Frederic Clere
                  Reporter:
                  bmathus Baptiste MATHUS
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: