Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 5.4.2-fuse-00-00
    • Fix Version/s: 5.4.2-fuse-02-00
    • Component/s: None
    • Labels:
      None
    • Environment:
      Fuse MB 5.4.x
    • Similar Issues:
      Show 10 results 

      Description

      If we would like to subscribe through a virtual queue to the topic topic://test.> in theory we should subscribe to the queue queue://Consumer.a.test.>

      Unfortunately this doesn't work because the queue queue://Consumer.a.test.> is not created at the subscription step.

      However, if we create the queue queue://Consumer.a.test.> , for instance sending a message to it, we will have the expected virtual destination behavior.

      Looking at the virtual destinations semantic, subscribing to queue://Consumer.a.test.> should create the queue queue://Consumer.a.test.>

        Activity

        Dave Stanley
        added a comment -

        Attaching testcase

        Show
        Dave Stanley
        added a comment - Attaching testcase
        Dave Stanley
        added a comment -

        Tracking, comment from Dejan

        It will not work at the moment. The "problem" is that when you subscribe with the wildcard consumer, no destinations will be created. And the filter that implements virtual topics only send messages to pre-existing destinations.

        Show
        Dave Stanley
        added a comment - Tracking, comment from Dejan It will not work at the moment. The "problem" is that when you subscribe with the wildcard consumer, no destinations will be created. And the filter that implements virtual topics only send messages to pre-existing destinations.
        Dejan Bosanac
        added a comment -

        The issue is fixed and merged to fuse branch. You can test the latest (20110304.104603-14) snapshot

        http://repo.fusesource.com/nexus/content/repositories/snapshots/org/apache/activemq/apache-activemq/5.4.2-fuse-SNAPSHOT/

        Show
        Dejan Bosanac
        added a comment - The issue is fixed and merged to fuse branch. You can test the latest (20110304.104603-14) snapshot http://repo.fusesource.com/nexus/content/repositories/snapshots/org/apache/activemq/apache-activemq/5.4.2-fuse-SNAPSHOT/

          People

          • Assignee:
            Dejan Bosanac
            Reporter:
            Dave Stanley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: