Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-9272

NullPointer if truststore password is missing

    Details

    • Type: Bug
    • Status: Plan (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 4.8.1.Final
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      JBoss EAP7.1
      keycloak-wildfly-adapter-dist-4.8.2.Final
      Windows10 Enterprise

    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      If I define a secure-deployment in my standalone.xml like the following:

      <subsystem xmlns="urn:jboss:domain:keycloak:1.1">
                  <realm name="myRealm">
                      <auth-server-url>https://localhost:8443/auth</auth-server-url>
                      <truststore>D:/Projekte/extern/my_app/config/dev/cacerts</truststore>
                      <ssl-required>external</ssl-required>
                  </realm>
                  <secure-deployment name="dvdv2-adminclient.war">
                      <realm>myRealm</realm>
                      <resource>client_id</resource>
                      <credential name="secret">my_secret</credential>
                  </secure-deployment>
              </subsystem>
      

      I get a NullPointerException because the password is missing. But in case of JKS and JCEKS keystores the password is not necessary to read the certificate entries. This is only needed for PKCS12

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                captain_goldfish asdf asdf
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: