Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-8139

Align tests, documentation and downloads with supported Wildfly adapters

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 4.3.0.Final
    • Fix Version/s: 4.4.0.Final
    • Component/s: None
    • Labels:
    • Epic Link:
    • Sprint:
      Keycloak Sprint 11
    • Story Points:
      3
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      Discussion on which Wildfly adapters should we support started by Stian on ML: http://lists.jboss.org/pipermail/keycloak-user/2018-August/015312.html

      Based on the output and the decision, which wildfly adapters to support/deprecate/remove, we may need to:

      • Remove "wildfly9" and "wildfly10" modules for adapters testing from our testsuite (if we decide to deprecate/remove wildfly9 and wildfly10 adapters)
      • Add the "wildfly11" module to our testsuite (if we decide to support "wildfly11" adapter. But so far, it looks that it may be rather deprecated). In this case ConsoleProtectionTest will need to run with Wildfly 11.
      • Update downloads page and documentation accordingly (EG. Add wildfly13 adapter, deprecate Wildfly 9-11 adapters)

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                mposolda Marek Posolda
                Reporter:
                mposolda Marek Posolda
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: