Uploaded image for project: 'Keycloak'
  1. Keycloak
  2. KEYCLOAK-1439

Admin Console is not loaded when Keycloak is installed as root context

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.2.0.Final
    • Fix Version/s: 1.3.1.Final
    • Component/s: None
    • Labels:
      None

      Description

      Keycloak Admin Console cannot load JS adapter.
      Pretty trivial bug, patch as follows:

      Index: forms/common-themes/src/main/resources/theme/base/admin/index.ftl
      <+>UTF-8
      ===================================================================
      --- forms/common-themes/src/main/resources/theme/base/admin/index.ftl	(revision d8880e5ff3f234e5fb1225fa5fc98e46f28d8966)
      +++ forms/common-themes/src/main/resources/theme/base/admin/index.ftl	(revision )
      @@ -27,7 +27,7 @@
           <script src="${resourceUrl}/lib/fileupload/angular-file-upload.min.js"></script>
           <script src="${resourceUrl}/lib/filesaver/FileSaver.js"></script>
       
      -    <script src="/auth/js/${resourceVersion}/keycloak.js" type="text/javascript"></script>
      +    <script src="${authUrl}/js/${resourceVersion}/keycloak.js" type="text/javascript"></script>
       
           <script src="${resourceUrl}/js/app.js" type="text/javascript"></script>
           <script src="${resourceUrl}/js/controllers/realm.js" type="text/javascript"></script>
      \ No newline at end of file
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                roman.usatenko Roman Usatenko
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: