Uploaded image for project: 'JBoss Web'
  1. JBoss Web
  2. JBWEB-108

Please update JDT Compiler or provide a JCI compiler

    Details

    • Type: Feature Request
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: JBossWeb-2.1.1.GA
    • Component/s: None
    • Labels:
      None

      Description

      Tomcat uses a very old version of the JDT Compiler, not supported by the commons JCI compiler adapter. This means that Drools has to use the Janino compiler, which is not JDK1.5 compliant. If you where to use JCI itself you would benefit from a pluggable compiler interface. I'd also recommend not polluting the user classpath space with tomcat dependencies.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                rmaucher Valued Customer
                Reporter:
                mark.proctor Mark Proctor
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: