Uploaded image for project: 'JBoss Transaction Manager'
  1. JBoss Transaction Manager
  2. JBTM-2942

LRA tests failed when building with the JDK9

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 5.7.0.Final
    • Fix Version/s: 5.9.1.Final
    • Component/s: LRA
    • Labels:

      Description

      The lra-test still failed with java.lang.IllegalArgumentException when deploying the war. It looks like the wildfly-swarm does support the JDK9 currently. Also I find 1 and 2 with the same issues.

      1. https://stackoverflow.com/questions/46449735/wildfly-swarm-deployment-crash-with-java-9
      2. https://stackoverflow.com/questions/42990017/illegalargumentexception-while-starting-wildfly-swarm-provided-custom-main-meth

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  mmusgrov Michael Musgrove
                  Reporter:
                  zhfeng Zheng Feng
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: