Uploaded image for project: 'JBoss Transaction Manager'
  1. JBoss Transaction Manager
  2. JBTM-1634

TX tests failed with "Unable to start a new txn on URI"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 5.0.0.M3
    • Component/s: BlackTie
    • Labels:
      None

      Description

      http://172.17.131.2/job/blacktie-windows2008-taconic/246/
      http://172.17.131.2/job/blacktie-linux32/915/
      http://172.17.131.2/job/blacktie-linux64/1472/

      2013-04-16 06:12:25,324 [0x57fb3f0] DEBUG (HttpClient               :114 ) - connected to TM on localhost:8080 URI=http://localhost:8080/rest-tx/tx/transaction-manager
      2013-04-16 06:12:25,484 [0x57fb3f0] DEBUG (HttpClient               :74  ) - connect to localhost:8080 ok
      2013-04-16 06:12:25,491 [0x57fb3f0] DEBUG (HttpClient               :99  ) - POST http://localhost:8080/rest-tx/tx/transaction-manager HTTP/1.1
      
      2013-04-16 06:12:25,495 [0x57fb3f0] DEBUG (HttpClient               :99  ) - Host: localhost
      
      2013-04-16 06:12:25,498 [0x57fb3f0] DEBUG (HttpClient               :99  ) - Content-Length: 13
      
      2013-04-16 06:12:25,500 [0x57fb3f0] DEBUG (HttpClient               :99  ) - Content-Type: application/x-www-form-urlencoded
      
      2013-04-16 06:12:25,505 [0x57fb3f0] DEBUG (HttpClient               :148 ) - timeout=-1000
      2013-04-16 06:12:25,508 [0x57fb3f0] DEBUG (HttpClient               :158 ) - buf size is 4096
      2013-04-16 06:12:27,023 [0x57fb3f0] DEBUG (HttpClient               :162 ) - receive 241 bytes
      2013-04-16 06:12:27,028 [0x57fb3f0] DEBUG (HttpClient               :165 ) - HTTP/1.1 404 Not Found
      Content-Length: 145
      Connection: keep-alive
      Content-Type: text/html
      
      Could not find resource for relative : /rest-tx/tx/transaction-manager of full path: http://localhosthttp/rest-tx/rest-tx/tx/transaction-manager?
      2013-04-16 06:12:27,049 [0x57fb3f0] DEBUG (HttpClient               :194 ) - HTTP/1.1 404 Not Found
      

      It looks like restat-web.war has not regiter as /rest-tx

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                zhfeng Zheng Feng
                Reporter:
                zhfeng Zheng Feng
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: