Uploaded image for project: 'Seam 2'
  1. Seam 2
  2. JBSEAM-2864

Injection not working with concurrent clients

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Out of Date
    • Affects Version/s: 2.0.1.CR1, 2.0.1.CR2, 2.0.1.GA
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Jboss AS 4.2.2.GA, Windows

      Description

      When I was loading testing my application I was getting some NPE.
      I narrowed down the error and created the example app based on a seam-gen one (just stripped the lib directory).

      Basically, what I want to execute the place GET at the following URLs:
      http://localhost:8080/myproject/performance/startsession.seam
      http://localhost:8080/myproject/performance/start.seam
      http://localhost:8080/myproject/performance/search.seam?parameter=1&cid=2
      http://localhost:8080/myproject/performance/end.seam?cid=2

      If after you start jboss you execute the above it goes ok. The debug page shows that the long-running conversation is gone and everything is ok.

      Then I created a JMeter test, just capturing the "cid" from start, and use it at search and end page (see attached jmeter test). If you run the script with 1 thread no loop, it goes ok. If you run with 5 (in my pc) it goes ok. But when you put more then 20, it starts to get NPE at SimpleAction#search when it calls the DAO.
      The log at search.xhtml shows the error and the sysos at SimpleAction#search shows it as well.

      Please, provide a workaround in 2.0.1.CR1.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                barbacena Marcell
              • Votes:
                10 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: