Uploaded image for project: 'JBoss Portal'
  1. JBoss Portal
  2. JBPORTAL-2157

User not notified when uploading nonexisting / wrong type archive in CMS

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.6.6 Final
    • Fix Version/s: 2.7.1 Final, 2.6.8 Final
    • Component/s: Portal CMS
    • Labels:
      None
    • Environment:

      fedora 9, laptop t61, java version "1.5.0_16", firefox 3.0.1

      Description

      Interesting issue. In CMS admin interface it is able to upload an archive file into the CMS. It's done by "Select action" selector in "Manage Content" in the CMS tab. Selecting "Upload archive" opens the form where it is able to choose the archive.

      The is a special situation:
      1. Choose the file (but don't click the "Upload" button!)
      2. Delete the file on disk or move the file to other location
      3. Click Upload button

      The message "Your archive has been accepted for processing. The resources will appear in your Folder once the processing is finished" it written on the screen, even if the file does not exist.
      The same message is written the file uploaded by "upload archive" form is not an archive (but i.e. jpg file)

      I guess this should be not the correct behavior.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  soshah Sohil Shah
                  Reporter:
                  vrockai Viliam Rockai
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: